sexta-feira, agosto 16, 2019

ERROR: homeassistant requires Python '>=3.6.0' but the running Python is 3.5.3

rm -rf /srv/homeassistant

apt install python3.6-dev
pip3 install zeroconf


sudo add-apt-repository ppa:jonathonf/python-3.6 sudo apt-get update sudo apt-get install python3.6 sudo update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.6 2 sudo apt-get install python3-venv


sudo rm -r Python-3.6.5
 rm Python-3.6.5.tar.xz
exit
 sudo apt-get --purge remove build-essential tk-dev
 sudo apt-get --purge remove libncurses5-dev libncursesw5-dev libreadline6-dev
 sudo apt-get --purge remove libdb5.3-dev libgdbm-dev libsqlite3-dev libssl-dev
 sudo apt-get --purge remove libbz2-dev libexpat1-dev liblzma-dev zlib1g-dev
 sudo apt-get autoremove
 sudo apt-get clean


depois é só usar
python3.6 -m venv homeassistant


Sem comentários:

LinkWithin

Related Posts Widget for Blogs by LinkWithin